Foreslå readonly

En god facilitet i vb edtitoren er readonly recomended. Ved at gå ind i vb editoren med alt f11 og vælge project explorer, markere this worksheet,  og vælg readonly recomende true. Hermed opnåes det at læseren af rapporten som udgangspunkt foreslås at man åbner rapporten som readonly. Hermed bliver der bedre mulighed for at de medarbejdere, der skal arbejde i rapporten kan komme til.

 

LOPSLAG:

Funktionen LOPSLAG er velegnet, hvis man i en rapport skal benytte data fra flere datalister. Ved hjælp af LOPSLAG kan man flette datalisterne sammen.
52 a

http://www.youtube.com/watch?v=XsGeAcdJiUA

Man kan også anvende  dobbelt lopslagsfunktion til dette arbejde, som det vises i denne video:

52 b

 

 https://www.youtube.com/watch?v=zkecIk3YRlA


Lopslags funktionen kan nogle gange volde problemer, hvis der er forskellige formatteringer i regnearket. Dette kan der rodes bod vha. søg og erstat funktionen.


Tast ctrl + H

Vælg erstat og skriv den opslagsværdi der volder problemer i både søg og erstat.Det er vigtigt at man i søg vælger format ikke angivet, hvorimod at man i erstat skal klikke på det format man ønsker overført til hele mappen. Vælg at erstatte i hele projektmappen. Herefter får opslagsværdien samme formattering i projektmappen og Lopslags funktionen virker igen

Et andet problem med Lopslag funktionen er at man får #NA melding når værdien ikke findes.

Dette kan der rodes bod på ved at følge videon her:
53

http://www.youtube.com/watch?v=lQCdgU4yHxA

Den danske formelsyntaks er:

=+HVIS.FEJL(LOPSLAG(BS6;Handlinger_Spm;2;0);"")

I nedenstående formel søges der først i DB_1 herefter i DB_2 og hvis der ikke er noget der matcher i DB_2 skrives der -.

=IFERROR(VLOOKUP(H5;DB_1;2;FALSE);IFERROR(VLOOKUP(H5;DB_2;2;FALSE);"-"))



Indirekte:

Et stærkt opslagsværktøj fås også ved at bruge Indirekte funktionaliteten, som især er nyttig ved opslag i tabeller med flere rækker og kolonner.
53
http://www.youtube.com/watch?v=L6Ow1wLfw2Q



SUM.Hvis:

Funktionen Sum.hvis er til stor gavn, hvis man skal  skal summere data i indenfor en række kategorier.
54

http://www.youtube.com/watch?v=sKEDjxI2FU4

Udfyld tomme celler:
Hvis man er nødt til at hardcopy data fra en pivot tabel og gerne vil have udfyldt de tomme celler, så kan det gøres ved at oprette en kolonne ved siden af og anvende følgende formel:

=hvis(a2<>"";a2;b1)

Summering uden dobbeltberegning af delsummer fås med formlen:

=+SUBTOTAL(9;C2:C4)

Husk at anvende den konsekvent i alle summering på siden, ellers virker den ikke !

 

Arrays:

En formel som denne kan erstattes

=SUM(B2*B3;C2*C3;D2*D3)

Med

{=SUM(B2:D2*B3:D3)}

Skriv blot formel og gå herefter op øverst i excel vindue hvor formlen og tryk ctrl + shift + enter

 

Hermed kan du forsimple dine formler !